Tag Archives: ror

which subversion will submit itself to my feet?

Please help me in this.I am trying to deploy my Rails app on my bluehost domain.The tutorial mentioned in the bluehost sucks and doesn’t seem to work though I am getting this screen but again with a 404 not found message in place of … (server info??)

WTF ?

WTF ?

I asked the help from Bluehost’s Live chat but there doesn’t seem to be any solid support guy who can guide me on this.Even the ROR guide mentioned in the Knowledge base seems to be an outdated one.

I asked about using Subversioning as mentioned in various blogs about deployment in rails.They said they do not endorse SVN for their host though we can do that…Chat closed..

WTH

There are so many ways to deploy rails application…though I still not able to figure out what is using which strategy.I was following blindly whatever was mentioned in the blogs.

This is my current stop at deployment effort.

http://www.codeweblog.com/capistrano-automatic-deployment-of-rails-projects-windows-to-bluehost-fastdomain/

Which asks for installing SVN client on my host… and for installing SVN this is the blog i am following

http://www.tabruyn.com/site/index.php?option=com_content&view=article&id=55:tortoisesvn-subversion-and-bluehost&catid=36:digital&Itemid=58

I found that apr and apr-util versions are outdated ones so I went to the gtlib,gatech.edu and downloaded the latest versions of apr and apr-util that is apr-1.3.5 and apr-util-1.3.7.

then I downloaded neon-0.28.0. I don’t know what is that for ???

then the subversion 1.6.3 then 1.4.6. I am able to MAKE apr and apr-util versions and also the neon versions but the SVN 1.6.3 said that the SVN is not compatible with apr-version so I tried making SVN 1.4.6 which was compatible with apr-1.3.5 but was not compatible with apr-util-1.3.7

The odd men here is the SVN 1.4 and 1.6 versions ..help needed

The odd men here is the SVN 1.4 and 1.6 versions ..help needed

What I need is a proper version of SVN that can work with the following :

  • apr-1.3.5
  • apr-util-1.3.7
  • neon-0.28.0

I need help …if you have any easier way ..ONE CLICK DEPLOYMENT for RAILS please suggest me

Advertisements